Build: #26 failed Manual run by Dawid Weiss

Stages & jobs

  1. check linux

  2. check platforms

Build result summary

Details

Completed
Duration
5 seconds
Labels
None
Revision
86e726dd9ba458ac904819118bcb65e923791aa7 86e726dd9ba458ac904819118bcb65e923791aa7
Failing since
#25 (Changes by Dawid Weiss)
Fixed in
#28 (Manual run by Dawid Weiss)

No failed tests found, a possible compilation error occurred.

Responsible

Error summary for check-linux

The job generated some errors, drill down into the full build log for more details.


FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'procfork'.
> Could not resolve all files for configuration ':classpath'.
   > Could not resolve com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0.
     Required by:
         project : > com.palantir.consistent-versions:com.palantir.consistent-versions.gradle.plugin:2.5.0
      > No matching variant of com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0 was found. The consumer was configured to find a runtime of a library compatible with Java 9, packaged as a jar, and its dependencies declared externally, as well as attribute 'org.gradle.plugin.api-version' with value '7.3' but:
          - Variant 'apiElements' capability com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0 declares a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares an API of a component compatible with Java 11 and the consumer needed a runtime of a component compatible with Java 9
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.3')
          - Variant 'javadocElements' capability com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0 declares a runtime of a component, and its dependencies declared externally:
              - Incompatible because this component declares documentation and the consumer needed a library
              - Other compatible attributes:
                  - Doesn't say anything about its target Java version (required compatibility with Java 9)
                  - Doesn't say anything about its elements (required them packaged as a jar)
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.3')
          - Variant 'runtimeElements' capability com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares a component compatible with Java 11 and the consumer needed a component compatible with Java 9
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.3')
          - Variant 'sourcesElements' capability com.palantir.gradle.consistentversions:gradle-consistent-versions:2.5.0 declares a runtime of a component, and its dependencies declared externally:
              - Incompatible because this component declares documentation and the consumer needed a library
              - Other compatible attributes:
                  - Doesn't say anything about its target Java version (required compatibility with Java 9)
                  - Doesn't say anything about its elements (required them packaged as a jar)
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.3')

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3s