Build #410

Build: #410 was successful

Job: JDK 14 (Linux) was successful

Stages & jobs

  1. Compile and test

  2. Follow ups

Job result summary

Completed
Duration
3 minutes
Agent
Linux Agent 1
Revision
76604afaeadc09dbf0085fdc40817fc7aeb22995 76604afaeadc09dbf0085fdc40817fc7aeb22995
Total tests
418
Successful since
#401 ()

Tests

  • 418 tests in total
  • 7 tests were quarantined / skipped
  • 42 seconds taken in total.

Error summary

The build generated some errors. See the full build log for more details.

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.codehaus.groovy.reflection.CachedClass (file:/home/bamboo/.gradle/wrapper/dists/gradle-6.6.1-all/ejrtlte9hlw8v6ii20a9584rs/gradle-6.6.1/lib/groovy-all-1.3-2.5.12.jar) to method java.util.AbstractCollection.finishToArray(java.lang.Object[],java.util.Iterator)
WARNING: Please consider reporting this to the maintainers of org.codehaus.groovy.reflection.CachedClass
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
warning " > craco-raw-loader@1.0.1" has incorrect peer dependency "@craco/craco@^3.3.1".
warning " > craco-raw-loader@1.0.1" has incorrect peer dependency "react-scripts@^2.1.3".
warning "craco-raw-loader > raw-loader@1.0.0" has unmet peer dependency "webpack@^4.3.0".
warning " > raw-loader@4.0.2" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
warning "react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
craco:  *** Cannot find ESLint loader (eslint-loader). ***
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade`
warning "@carrotsearch/gatsby-theme-apidocs > gatsby-link@2.4.14" has unmet peer dependency "@reach/router@^1.3.3".
warning " > gatsby@2.27.4" has unmet peer dependency "react@^16.4.2".
warning " > gatsby@2.27.4" has unmet peer dependency "react-dom@^16.4.2".
warning "gatsby > @reach/router@1.3.4" has unmet peer dependency "react@15.x || 16.x || 16.4.0-alpha.0911da3".
warning "gatsby > @reach/router@1.3.4" has unmet peer dependency "react-dom@15.x || 16.x || 16.4.0-alpha.0911da3".
warning "gatsby > gatsby-link@2.6.1" has unmet peer dependency "react@^16.4.2".
warning "gatsby > gatsby-link@2.6.1" has unmet peer dependency "react-dom@^16.4.2".
warning "gatsby > gatsby-react-router-scroll@3.2.0" has unmet peer dependency "react@^16.4.2".
warning "gatsby > gatsby-react-router-scroll@3.2.0" has unmet peer dependency "react-dom@^16.4.2".
warning "gatsby > react-hot-loader@4.13.0" has unmet peer dependency "react@^15.0.0 || ^16.0.0 || ^17.0.0 ".
warning "gatsby > react-hot-loader@4.13.0" has unmet peer dependency "react-dom@^15.0.0 || ^16.0.0 || ^17.0.0 ".
warning "gatsby > @reach/router > create-react-context@0.3.0" has unmet peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0".
warning "gatsby > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
warning "gatsby > eslint-plugin-graphql > graphql-config > @endemolshinegroup/cosmiconfig-typescript-loader > ts-node@9.0.0" has unmet peer dependency "typescript@>=2.7".